View Ticket
Not logged in
Ticket Hash: 6faa96eb5d8bf79efb2885a10c1c131bcc82056c
Title: Please update config.guess to support RISC-V
Status: Open Type: Build_Problem
Severity: Minor Priority:
Subsystem: Resolution:
Last Modified: 2022-08-19 05:42:44
Version Found In: 5.0.1
User Comments:
anonymous added on 2022-08-19 05:42:44: (text/x-markdown)
Hi, I'm trying to port libspatialite to RISC-V. When executing `./configure`, an error occurred.

```
checking build system type... ./config.guess: unable to guess system type

This script, last modified 2009-11-20, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from

  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
and
  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD

If the version you run (./config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <config-patches@gnu.org> in order to provide the needed
information to handle your system.

config.guess timestamp = 2009-11-20

uname -m = riscv64
uname -r = 5.18.15-arch1-2
uname -s = Linux
uname -v = #1 SMP PREEMPT_DYNAMIC Mon, 01 Aug 2022 18:58:16 +0000

/usr/bin/uname -p = unknown
/bin/uname -X     = 

hostinfo               = 
/bin/universe          = 
/usr/bin/arch -k       = 
/bin/arch              = 
/usr/bin/oslevel       = 
/usr/convex/getsysinfo = 

UNAME_MACHINE = riscv64
UNAME_RELEASE = 5.18.15-arch1-2
UNAME_SYSTEM  = Linux
UNAME_VERSION = #1 SMP PREEMPT_DYNAMIC Mon, 01 Aug 2022 18:58:16 +0000
configure: error: cannot guess build type; you must specify one
```

As far as I know, more recent version of config.guess and config.sub can recognize riscv64. And I can build libspatialite successfully after executing `autoreconf -fiv`. Could you please update config.guess and config.sub?