Ticket Change Details
Not logged in
Overview

Artifact ID: 77385782d1eeb814e612889cde6bb65d8190a8ae
Ticket: 6af9a4f1ffef472c11a11a8358ba79d9b70b7ca4
config.sub/config.guess are very old
Date: 2020-07-27 18:52:23
User: anonymous
Changes

  1. Change foundin to "4.3.0a"
  2. Change icomment to:

    In libspatialite 4.3.0a, config.sub/config.guess are very old (timestamp='2009-11-20'). This prevents building for newer architectures. For example,

    ./configure --build=x86_64-linux-gnu --host=aarch64-linux-gnu ... checking host system type... Invalid configuration `aarch64-linux-gnu': machine `aarch64' not recognized configure: error: /bin/sh ./config.sub aarch64-linux-gnu failed

    If I update to the latest config.sub/config.guess (from git.savannah.gnu.org with timestamp='2020-07-12'), I'm able to build for more arches (such as aarch64).

    libspatialite should update to the latest config.sub/config.guess so we don't have to do these workarounds.

  3. Change login to "anonymous"
  4. Change mimetype to "text/plain"
  5. Change private_contact to "efcaec14c0d25f4ea14cc201021689b6044f32c1"
  6. Change severity to "Important"
  7. Change status to "Open"
  8. Change title to "config.sub/config.guess are very old"
  9. Change type to "Build_Problem"